Installing PostGIS 3.1 on CentOS 8 requires a few steps:
Run these steps as root:

- Install PostgreSQL repo RPM:

dnf -y install https://download.postgresql.org/pub/repos/yum/reporpms/EL-8-x86_64/pgdg-redhat-repo-latest.noarch.rpm

- Disable postgresql module:

dnf -qy module disable postgresql

- Install EPEL repo RPM:

dnf -y install epel-release

- Enable PowerTools repo (required for some of the dependencies):

dnf -y config-manager --set-enabled PowerTools

- Now, you can finally install PostGIS:

dnf -y install postgis31_13

- The last step is creating the extension:

CREATE EXTENSION postgis;

Please refer to PostGIS documentation for more info:

http://postgis.net/docs/manual-3.1/

34 Comments

Threaded

The author does not allow comments to this entry